We are experiencing an issue with our database connections
Major incident
Tribepad Pro Talent Acquisition Platform (Rochdale DC)
2026-08-12 10:20 BST
· 1 hour, 11 minutes
Updates
Resolved
August 12, 2026 · 11:31 BST
Services are now fully resumed and the team will be making changes in the background to ensure that this does not happen in the future. Thanks for your patience
Monitoring
August 12, 2026 · 10:40 BST
The team have identified the cause, and the connection now looks to be stabilising. We will continue to monitor this, but users should now be able to resume services. Please be aware that services may still be slightly slower than normal whilst the connection resumes to capacity.
Issue
August 12, 2026 · 10:20 BST
We are currently experiencing an issue with our database connection. This is currently being investigated. You may find that some users are experiencing errors and unable to access the platform.
← Back
Status