Candidate Interviews Problem

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2026-07-16 16:09 BST · 1 hour, 24 minutes

Updates

Resolved

The team’s changes were successful, and this was pushed through a live deployment. Candidates should now be able to book in for Interview slots as expected

July 16, 2026 · 17:33 BST
Update

Our team have identified the problem and changes are currently being made. The changes are being tested before it is goes through a live deployment

July 16, 2026 · 17:15 BST
Issue

We are aware of a problem with candidates unable to select any interview slots. Our team are aware of this and looking into the problem. We will provide updates as soon as we know more

July 16, 2026 · 16:09 BST

← Back