ATS platform down

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2026-07-09 08:53 BST · 2 hours, 37 minutes

Updates

Resolved

We can see that the platform looks to be stable all users should be able to log in as anticipated

July 9, 2026 · 11:26 BST
Monitoring

The platform looks to be returned and users should now be able to log in as anticipated.

The team are still monitoring on our side

July 9, 2026 · 08:57 BST
Issue

Some users may find they are unable to log into the platform this morning. Our development team are looking further into this at the moment.

As soon as we have any further information on this we will update you

July 9, 2026 · 08:53 BST

← Back