Job Requisitions page

Minor incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2026-06-04 15:27 BST · 56 minutes

Updates

Resolved

The teams changes were successful, and this has now been pushed through a live deployment. Job Requistions should now be visible to view on the jobs list page.

June 4, 2026 · 16:23 BST
Investigating

The team have identified the problem and a change is being made. This change is running through their end to end testing cycle before we push this through a live deployment

June 4, 2026 · 15:42 BST
Issue

We have identified a problem within Job Requsitions where the page is not loading for users under the Jobs List View. The team are currently investigating the matter in order to resolve this

June 4, 2026 · 15:27 BST

← Back