Integration issue with Trust ID

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2026-03-31 11:47 BST · 3 hours, 13 minutes

Updates

Resolved

Thank you for your patience.

For all customer whom use Trust ID/Tribepad checks.

We have had an update from Trust ID/Tribepad check that this issue has now been resolved on their side. And the system should now be working.

March 31, 2026 · 14:51 BST
Issue

We have been informed by our third-party integration provider, Trust ID.

That they are currenlty exerpiencing intermitted outages with their platform. They have advised that this may result in an inability to send and receive checks or slow speeds.
Trust ID’s development team are investigating this issue on their side.

Sorry for the inconvenience this will cause.

March 31, 2026 · 11:47 BST

← Back