Slowness

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC)
2026-02-23 10:40 GMT · 1 hour, 26 minutes

Updates

Resolved

Thank you for your patience while our team investigated this issue.

After monitoring the situation, we’re pleased to confirm that a resolution has been implemented and the system is now fully operational.

If you experience any further issues, please don’t hesitate to let us know.

February 23, 2026 · 11:59 GMT
Issue

Our team is aware of intermittent slowness affecting certain areas of the platform. This issue is currently under active investigation, and we are working to resolve it as quickly as possible.
We appreciate your patience and understanding.

February 23, 2026 · 10:40 GMT

← Back