Right to Work "loading" message.

Minor incident Tribepad Pro Talent Acquisition Platform (Rochdale DC)
2026-01-27 10:13 GMT · 5 hours, 3 minutes

Updates

Resolved

The issue that caused some users to see a “Loading” message when attempting to view Right to Work reports has now been fully resolved. Our fix has successfully completed end-to-end testing and is live. Users should now be able to access reports as normal. Thank you for your patience while we worked to resolve this.

January 27, 2026 · 15:16 GMT
Issue

We’re aware of an issue causing some users to see a “Loading” message when attempting to view Right to Work reports. Our development team has identified the cause and deployed a fix, which is currently progressing through end-to-end testing. We’ll provide a further update once testing is complete.

January 27, 2026 · 10:13 GMT

← Back