3rd party ticketing system outage

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2025-12-05 09:08 GMT · 32 minutes

Updates

Resolved

Thank you for your patiance the 3rd party ticketing system is now operational. Please note there may still be some delay while the system gets back up to speed.

December 5, 2025 · 09:35 GMT
Issue

We are currently aware that our 3rd party ticket system is experiencing an outage. This also affects our learn site as soon as we have any further update from the 3rd party, we will update you with this.

Thank you for your patiance.

December 5, 2025 · 09:08 GMT

← Back