ATS Downtime

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC)
2025-11-18 12:08 GMT · 8 hours, 44 minutes

Updates

Resolved

This incident is now resolved and sites are fully functioning as expected once again. Thank you for your patience while we waited for Cloudflare to come back online.

November 18, 2025 · 17:00 GMT
Monitoring

Cloudflare have now marked this incident as resolved and our sites now appearing to functioning as expected once again. We will keep monitoring this over the coming hours.

Cloudflare: A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.

November 18, 2025 · 15:01 GMT
Issue

The Cloudflare Global Network is currently experiencing issues - https://www.cloudflarestatus.com

This is resulting in some of our sites experiencing some downtime. We are actively monitoring this and will let you know as soon as we have any updates.

Thank you for your patience.

November 18, 2025 · 12:08 GMT

← Back