emergency maintenance
Major incident
Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2025-10-28 11:06 GMT
· 14 minutes
Updates
Resolved
October 28, 2025 · 11:20 GMT
We’re happy to let you know that the upgrade has been completed and all services are now running smoothly.
Thank you for your patience while we performed this maintenance, we appreciate your understanding and are committed to keeping your experience seamless.
Issue
October 28, 2025 · 11:06 GMT
We are aware of an issue which may be impacting performance and are performing emergency maintenance to upgrade the part of the platform in question, you may have a brief interruption to service.
We appreciate your patience and are working to get everything running smoothly as quickly as possible.
← Back
Status