New roles not appearing on the Indeed job feed.

Major incident Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London)
2025-10-14 08:58 BST · 2 hours, 42 minutes

Updates

Resolved

We’re happy to let you know that the issue affecting the visibility of jobs on the Indeed job feed has now been resolved.

Our development team identified the problem and has implemented a fix — new roles are now appearing as expected in the feed.

We understand how important it is for your job listings to be visible, and we’re sorry for any inconvenience this may have caused. Thank you for your patience while we worked to get everything back on track.

October 14, 2025 · 11:40 BST
Update

Our team is still actively working on resolving the issue that’s preventing new roles from appearing in the Indeed job feed.

We don’t have any new updates to share just yet, but please rest assured this remains a top priority for us. We’ll keep you updated as soon as there’s more to report.

We really appreciate your understanding while we work through this.

October 14, 2025 · 10:03 BST
Issue

We’re currently experiencing an issue where new roles are not appearing in the Indeed job feed. Our team is actively investigating this and treating it as a top priority.

We’ll share updates here as soon as more information becomes available.

Thank you for your patience.

October 14, 2025 · 08:58 BST

← Back