ATS Slowness

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC)
2025-09-15 10:31 BST · 3 hours, 51 minutes

Updates

Resolved

The team have now looked into this issue and a resolution is now in place.

September 15, 2025 · 14:20 BST
Investigating

Holding pages are now down and our team are currently monitoring the platform.

September 15, 2025 · 12:44 BST
Investigating

We are putting up holding pages to allow us to do the necessary work with regard to this speed issue.
Many thanks,

September 15, 2025 · 10:57 BST
Issue

We are aware of some slowness when trying to access the ATS and loading pages.

The team are aware of this issue and is working on getting this resolved.

September 15, 2025 · 10:31 BST

← Back