Insights service is down

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Pro & Gro Talent Acquisition Platform (AWS London) Tribepad Insights (AWS London)
2025-07-15 15:21 BST · 25 minutes

Updates

Resolved

The incident with Insights has now been resolved and the site is working as expected. Thank you for your patience while the team worked on this.

July 15, 2025 · 15:48 BST
Issue

The Insights feature is currently presenting an error 500 on all pages. The team are working on this as a Priority level 1 incident. We will provide updates as soon as we can. Thank you for your patience.

July 15, 2025 · 15:21 BST

← Back