Jobs List
Major incident
Tribepad Pro Talent Acquisition Platform (Rochdale DC)
Tribepad Pro Talent Acquisition Platform (Sheffield DC)
Tribepad Gro Talent Acquisition Platform (AWS London)
2024-10-15 16:18 BST
· 1 hour, 20 minutes
Updates
Resolved
October 15, 2024 · 17:36 BST
The team has made a change so that the job list page should display the jobs again. If any users still experience issues, please clear your browsing history, cookies, and cache, which should resolve the problem for you.
Issue
October 15, 2024 · 16:18 BST
Some of our customers may be having difficulties in loading and viewing the Jobs List View. This is currently being looked to with our development team.
← Back