Delays in tracking information.

Minor incident Tribepad Pro Talent Acquisition Platform (Rochdale DC) Tribepad Pro Talent Acquisition Platform (Sheffield DC) Tribepad Gro Talent Acquisition Platform (AWS London) Tribepad Insights (AWS London)
2024-10-07 11:10 BST · 1 hour, 13 minutes

Updates

Resolved

The tracking issue should now be resolved for all customers.

October 7, 2024 · 12:23 BST
Investigating

We are aware that some customers may be experiencing delays in retrieving tracking information. Our team is actively investigating the cause and will provide further details as soon as they become available.

October 7, 2024 · 11:10 BST

← Back