Problems with emails sending

Major incident Tribepad Pro Talent Acquisition Platform (Rochdale DC)
2024-10-04 09:55 BST · 1 hour, 16 minutes

Updates

Resolved

The email issue the platform was experiencing this morning has now been resolved and emails are now sending as expected.

October 4, 2024 · 11:08 BST
Investigating

We are aware that some of our customers might be facing challenges with emails being sent. Our team is giving this issue top priority and working diligently to resolve it. We will send out further updates as they become available.

October 4, 2024 · 09:55 BST

← Back